1997 Pajero 3.5 GDI SWB Problem

Need some advise of a general nature not covered in the forums below? Here's where to do it.
Riaanvt
Country: Botswana
Vehicle: 1997 Pajero 3.5 GDI petrol SWB
Posts: 3
Joined: Mon Jan 21, 2019 9:15 am

1997 Pajero 3.5 GDI SWB Problem

Mon Jan 21, 2019 11:24 am

Good day all.

I'm Riaan and thank you for the approval.

I'm new here and new to the Pajero's , I hope you can help as I'm in Botswana (Francistown) and good help is hard to find here.
I just got a 1997 Pajero 3.5 GDI SWB from Japan.
1. As I drove the car is was pulling good (very strong) up to 4000 RPM then lost power but will rev up tp 6000 RPM.
I then decided to do the following , Oil, Oil filter , fuel filter and air filter.
After doing this (The basics ) the car would start but not idle.
If I push the accelerator it would start and idle up to 2000 RPM but will not rev up. The engine light started to flash.
I disconnected the battery to see if it would reset the light. This worked but then the car will idle (Now and then) but will not rev more than 3000 RPM .
I could not get 100% the correct fuel filter so I assumed it could be a flow problem and I have put the old filter back.
After doing this the same problem accrued with no idle.
I then removed the throttle body with the butterfly motor and sensor on the opposite side. I cleaned everything marking where everything goes and re assemble and fit to car.
Problem was still there. I then looked at the pump in the tank and found this to be new but tank was dirty. I removed the tank and rinsed it out and refitted.
Same problem.
Then I notice that if I get the car started and I touch the brake (Lights on only) I hear a knocking sound and the car wants to die. I found a solenoid under the Throttle body
with a white cone opening and closing . If I disconnect the plug the car does not wat to start at all.
Please advice and any comments are welcome.

Thank you
awie
Country: zambia
Vehicle: 1992 pajero swb 2000 pajero 3.5 gen3 !997 delica
Location: Kitwe
Posts: 9
Joined: Mon Mar 18, 2013 10:30 am

Re: 1997 Pajero 3.5 GDI SWB Problem

Tue Jan 29, 2019 10:00 pm

Hi Riaan

This car also have a high pressure pump between the banks at the back of the engine.

Inside the pump there are two micro filters which will be clogged and that is the cause of your headache. There are some backyard mechanics in Francistown who will know how to go about your problem.

There are some information on this topic in the POCUK forum. Hope this helps.
gillaniking
Country: pakistan
Vehicle: pajero
Posts: 4
Joined: Wed Sep 19, 2012 10:02 pm

Re: 1997 Pajero 3.5 GDI SWB Problem

Sun Feb 03, 2019 11:46 am

Hi there , flashing of ecu is not a good sign , it suggests some problem with either the wiring harness or malfunctioning sensors , first of all address this then u can go for fuel pressure check ups n replacement of microfilters
Nojotian
Country: Zimbabwe
Vehicle: Mitsubishi Pajero 3.5 V6 GDI
Posts: 11
Joined: Thu Mar 20, 2014 9:40 pm

Re: 1997 Pajero 3.5 GDI SWB Problem

Sun Feb 03, 2019 7:58 pm

Hie
My 1999 Gen 3 ex Jap 3,5 V6 GDI also had the same problem. The micro filters on the GDI high pressure pump between the cylinder banks had gotten clogged leading to a drastic loss of power and flashing engine check light. My local mechanic who is well versed in Pajeros opened the pump and removed the filters. He then installed an in-line fuel filter in the engine bay (apparently Pajeros dont have one!!) by cutting into the fuel supply line. Problem solved. He says its a common problem with GDI engines and "contaminated fuels". Now my service schedule includes a petrol filter change.

Hope that helps. Will post picture of the new setup.
[email protected]
Country: South Africa
Vehicle: Shogun 3,5 GDI
Posts: 17
Joined: Thu Sep 21, 2017 2:05 pm

Re: 1997 Pajero 3.5 GDI SWB Problem

Thu Feb 07, 2019 11:37 am

Hi hope you come right with this. I've got a 2001 Shogun ex UK. Similar fault fault code 56 low pressure. After reading comments and checking the UK site. Saw an inline filter added good idea in engine compartment. I've yet to work on mine as very little is mentioned in Haynes Manual. Would have been more logical fitting an inline filter than in the booster pump. Saw comments had no improvement in some cases. No one mentioned there's a pressure switch that sends a signal back. My plan is to remove it ensure clean good pressure is there. Also switches fail as if loss of signal during running will send it to limp. Good luck I'll check on future posts. Hi update after had time started to work on my fault. Stripped all pipes and various brackets managed to get to fuel pressure sensor. After lots of effort removed. Pressure switch is open circuit. Placed order Japan for a replacement. Agent 4900 plus vat Japan 2500. Awaiting delivery will remove high pressure pump check. But my cause is faulty pressure switch. Found fault diagnosis on Auto box section of manual.
Last edited by [email protected] on Thu Feb 28, 2019 8:35 am, edited 1 time in total.
Riaanvt
Country: Botswana
Vehicle: 1997 Pajero 3.5 GDI petrol SWB
Posts: 3
Joined: Mon Jan 21, 2019 9:15 am

Re: 1997 Pajero 3.5 GDI SWB Problem

Mon Feb 11, 2019 11:51 am

Good Day All

Thank you all for the reply's.

I had a "Bush mechanic " here with loads of experience on the Pajero's. He did remove the intake and Hi pressor pump , cleaned and
removed the 2x micro filters. The car does the same. The engine light is intermediate as sometimes it's off but still wont start.
If I do get it to start it will not rev more than 3000 rpm. I did check the Air flow sensor and fuel ECU on a newer GDI and both works 100%.
The rest I cant check as my car is a Gen 2 and the other one Gen3. The rest is all different.
I'm starting to think it's my main ECU that is in some sort of limp mode or broken.

If I find any other info or by some miracle get it fixed I will post it here so we all can have a look.
I will defiantly add the extra fuel filter in the engine bay that's a good idea.

Thanks

Return to “General Pajero Discussion”

Login · Register

Login  •  Register