Autobox problem

Transmissions, transfer boxes, axles, drive shafts
Dirty Dog
Country: South Africa
Vehicle: 2007 Pajero DiD LWB
Location: Swellendam
Posts: 7
Joined: Sat Sep 26, 2020 3:06 am

Autobox problem

Sun Nov 15, 2020 1:15 pm

I have the 2007 GEN4 DiD with autobox. I bought her 2nd hand and you get the feeling she had a busy life (224k km on the clock when bought). Everything is still perfect with her, except for some normal wear and tear. But the one thing that bothers me is that the gearbox seems to slip a bit when she's still cold. She hesitates when accelerating. I have checked the fluid level, and it does seem to be over filled. Would that cause the problem?

I've used her in deep beach sand at Arniston, and she seems to handle it without issues. What I have noticed is that if I even rest my hand on the gear selector, she will switch into neutral. Talking auto mode not manual shifting. I think I need to change the gearbox oil, and flush the system - was thinking of filling her after initial draining, driving for a few 100km and re-draining.

Any other suggestions?


User avatar
4ePikanini
Affiliate Member
Contact:
Country: South Africa
Vehicle: 2007 Pajero LWB 3.2 Di-D GLX
Location: East London, South Africa
Posts: 2812
Joined: Sun Jun 14, 2009 9:38 pm

Re: Autobox problem

Sun Nov 15, 2020 6:44 pm

Fill level needs to be checked on level ground while idling.

It does slip a bit when cold.

It should not go into neutral very easily from Drive.

Try an overnight battery disconnect to reset the gearbox computer.

Sent from my SM-A505F using Tapatalk

Dirty Dog
Country: South Africa
Vehicle: 2007 Pajero DiD LWB
Location: Swellendam
Posts: 7
Joined: Sat Sep 26, 2020 3:06 am

Re: Autobox problem

Mon Nov 16, 2020 9:50 am

I've already had it disconnected, seems to be the No 1 suggestion. I've also connected the OBDII and nothing shows up on the system.
BryanLog
Country: Australia
Vehicle: Pajero NX 3.2 Auto
Posts: 1
Joined: Wed Jun 17, 2020 12:25 pm

Re: Autobox problem

Tue Nov 17, 2020 11:59 am

Have you checked the shift selector cable adjustment on the side of the transmission is correctly adjusted ( this is in relation to when you touch the selector lever). I have had it previously when it came back from a service and they had obviously messed around in the the vicinity of the adjuster on the selector adjuster and shift selector shaft on the transmission.


Sent from my iPhone using Tapatalk
Dirty Dog
Country: South Africa
Vehicle: 2007 Pajero DiD LWB
Location: Swellendam
Posts: 7
Joined: Sat Sep 26, 2020 3:06 am

Re: Autobox problem

Tue Nov 17, 2020 3:02 pm

Thanks Bryan

I will check that out. sounds like a positive piece of information! Will feed back when I've checked it.

Return to “Drivetrain”

Login · Register

Latest Posts